Zyxel
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
SKU:GS1900-24EP-GB0101F
Low stock: 1 left
Couldn't load pickup availability
Delivery & lead times
Delivery & lead times
Some products ship directly from our suppliers and can have longer lead times than stock held in the UK. If you need a delivery date, please contact us before ordering. See our shipping policy.
Buying 5 or more? Volume pricing
Buying 5 or more? Volume pricing
We offer volume pricing, business accounts and quotations for organisations. Request a quote or call 01344 963637.
Returns & warranty
Returns & warranty
See our refund policy. Manufacturer warranty terms vary by product - contact us if you need warranty details before you buy.
- Managed L2
- Quality of Service (QoS) support
- Basic switching RJ-45 Ethernet ports quantity: 24
- Cat5, Cat5e
- MAC address table: 8000 entries Switching capacity: 48 Gbit/s
- Rack mounting Stackable
- AC Power supply included Power over Ethernet (PoE)
Near silent operation
The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.
Intelligent PoE+ powers more devices
PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.
Speedy Gigabit performance-built for SMBs
The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.
Easy and intuitive management
The Smart Managed GS1900 Series switch feature with web-based interface to manage advanced functions such as VLAN, QoS, IGMP Snooping, Link Aggregation (LAG), IPv6 and DoS prevention easily. Also, the user-friendly wizard helps to walk through setup, configuration and even advanced settings quickly.
| Management features | |
|---|---|
| Switch type | Managed |
| Switch layer | L2 |
| Quality of Service (QoS) support | Yes |
| MIB support | RFC 1213 MIB II RFC 2819 RMON (group 1, 2, 3, 9) RFC 1215 generic traps RFC 1493 bridge Zyxel private common MIB |
| Ports & interfaces | |
|---|---|
| Basic switching RJ-45 Ethernet ports quantity | 24 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Power connector | AC-in jack |
| Network | |
|---|---|
| Networking standards | IEEE 802.1D, IEEE 802.1ab, IEEE 802.1af, IEEE 802.1s, IEEE 802.1w, IEEE 802.3at, IEEE 802.3az, IEEE 802.3p, IEEE 802.3u, IEEE 802.3x |
| 10G support | No |
| Cable types supported | Cat5, Cat5e |
| Port mirroring | Yes |
| Full duplex | Yes |
| Ethernet LAN data rates | 10,100,1000 Mbit/s |
| MAC address auto-learning supported | Yes |
| Spanning tree protocol | No |
| Link aggregation | Yes |
| Auto MDI/MDI-X | Yes |
| Flow control support | Yes |
| VLAN support | Yes |
| Virtual LAN features | Tagged VLAN, VLAN Identifier ( VLAN ID), Voice VLAN |
| Data transmission | |
|---|---|
| MAC address table | 8000 entries |
| Switching capacity | 48 Gbit/s |
| Forwarding rate | 35.7 Mpps |
| Store-and-forward | Yes |
| Jumbo frames support | Yes |
| Jumbo frames | 9000 |
| Packet buffer memory | 0.525 MB |
| Security | |
|---|---|
| DHCP features | DHCP client |
| IGMP snooping | Yes |
| Static port security | Yes |
| Password protection | Yes |
| SSH/SSL support | Yes |
| Authentication type | HWTACACS+, IEEE 802.1x, RADIUS |
| Security algorithms | 802.1x RADIUS |
| MAC address filtering | Yes |
| Multicast features | |
|---|---|
| Multicast support | Yes |
| Design | |
|---|---|
| Rack mounting | Yes |
| Stackable | Yes |
| Product colour | Black |
| Reset button | Yes |
| Performance | |
|---|---|
| Noise level | 26 dB |
| Power | |
|---|---|
| Power source | AC |
| Power supply included | Yes |
| AC input voltage | 100 - 240 V |
| AC input frequency | 50/60 Hz |
| Power consumption (max) | 166.5 W |
| Power over Ethernet (PoE) | |
|---|---|
| Power over Ethernet (PoE) | Yes |
| Power over Ethernet (PoE) ports quantity | 12 |
| Total Power over Ethernet (PoE) budget | 130 W |
| Weight & dimensions | |
|---|---|
| Width | 330 mm |
| Depth | 230 mm |
| Height | 44 mm |
| Weight | 2.48 kg |
| Packaging data | |
|---|---|
| Cables included | AC |
| Quick start guide | Yes |
| Manual | Yes |
| User guide | Yes |
