Yealink
Yealink SIP-T58W IP phone Grey LCD Wi-Fi
Yealink SIP-T58W IP phone Grey LCD Wi-Fi
SKU:1301111
56 in stock
Couldn't load pickup availability
Delivery & lead times
Delivery & lead times
Some products ship directly from our suppliers and can have longer lead times than stock held in the UK. If you need a delivery date, please contact us before ordering. See our shipping policy.
Buying 5 or more? Volume pricing
Buying 5 or more? Volume pricing
We offer volume pricing, business accounts and quotations for organisations. Request a quote or call 01344 963637.
Returns & warranty
Returns & warranty
See our refund policy. Manufacturer warranty terms vary by product - contact us if you need warranty details before you buy.
Free from Cord Constraint, Free from Distracting Noise
Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.
The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.
Take Smart Business Phone to the Next Level
Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.
Enterprise-level Security, Provision and Management
Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.
By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.
| Design | |
|---|---|
| Wall mountable | Yes |
| Product colour | Grey |
| Handset type | Wired handset |
| Product type | IP Phone |
| Performance | |
|---|---|
| Hearing aid compatibility | Yes |
| Dual-Tone Multi-Frequency (DTMF) modes | In-band, Out-of band, SIP info |
| Phone features | |
|---|---|
| Caller ID | Yes |
| Call waiting | Yes |
| Speed dialling | Yes |
| Call hold | Yes |
| Call forwarding | Yes |
| Conference call | Yes |
| Redialing | Yes |
| Call park | Yes |
| Phonebook capacity | 1000 entries |
| Number of VoIP accounts | 12 |
| Call pick up | Yes |
| Anonymous call | Yes |
| Anonymous call rejection | Yes |
| Full duplex | Yes |
| Intercom | Yes |
| Do not disturb function | Yes |
| Call return | Yes |
| Call transfer | Yes |
| Message-waiting indicator (MWI) | Yes |
| Answering machine | Yes |
| Management features | |
|---|---|
| Keypad number of keys | 27 |
| Number of function keys | 7 |
| Integrated voicemail | Yes |
| Display | |
|---|---|
| Touchscreen type | Capacitive |
| Touchscreen | Yes |
| Display resolution | 1024 x 600 pixels |
| Display diagonal | 17.8 cm (7") |
| Display | LCD |
| Camera | |
|---|---|
| Rear camera | Yes |
| Front camera | Yes |
| Audio | |
|---|---|
| Voice codecs | G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC |
| Noise reduction | Yes |
| Voice activity detection | Yes |
| Adaptive jitter buffers | Yes |
| Automatic gain control | Yes |
| Comfort noise generation (CNG) | Yes |
| Packet loss concealment (PLC) | Yes |
| Microphone mute | Yes |
| Speakerphone | Yes |
| Video | |
|---|---|
| Video call | No |
| Network | |
|---|---|
| Supported network protocols | IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263) |
| Quality of Service (QoS) support | Yes |
| Security algorithms | 256-bit AES, HTTPS, TLS, WPA2, WPA3 |
| Networking standards | IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af |
| Bluetooth version | 4.2 |
| Bluetooth | Yes |
| Wi-Fi | Yes |
| Wi-Fi standards | 802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n) |
| Ethernet LAN data rates | 1000 Mbit/s |
| Ethernet LAN interface type | Gigabit Ethernet |
| Ethernet LAN | Yes |
| Ports & interfaces | |
|---|---|
| Ethernet LAN (RJ-45) ports | 2 |
| RJ-9 ports quantity | 2 |
| USB 2.0 ports quantity | 2 |
| Power | |
|---|---|
| Power over Ethernet (PoE) | Yes |
| Operational conditions | |
|---|---|
| Operating temperature (T-T) | 0 - 40 °C |
| Operating relative humidity (H-H) | 10 - 95% |
| Weight & dimensions | |
|---|---|
| Package weight | 9.56 kg |
| Package height | 128 mm |
| Package depth | 293 mm |
| Package width | 324 mm |
| Weight | 8.86 kg |
| Height | 215 mm |
| Depth | 220 mm |
| Width | 259.4 mm |
| Packaging content | |
|---|---|
| Number of handles included | 1 pc(s) |
